当前位置:首页 > 问答

通达信条件选股公式编写

我来帮TA回答

通达信中的公式:条件选股公式应当怎样编写,请高手指点。

您的这个情况很少有人会的,您可以看看百度经验的这个文章,http://jingyan.baidu.com/article/54b6b9c0ddbd6a2d583b47f4.html参考一下应该有帮助。

这样的通达信软件选股公式如何编写呢?条件如下,

count(a and b,n)>=1 and b;

通达信条件选股公式编写?

涨停回落:H/REF(C,1)>1.096 AND C<H;

因通达信不支持分时动态选取数据,你想收市后选股,现阶段不可能实现。只能改为11.30分停市时1点开市前就要进行用上面公式进行选取。
仅供参考,祝你好运!

通达信自编的选股公式如何使用

要改成选股公式,只能一条输出,其他都要加上等号.
公式一是可以的.
公式二要改一下.
--------------------
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
选股:DIF<0 AND DEA<0 AND CROSS(DIF,DEA);{低位金叉选股}
----------------------------
选股公式编到条件选股---其他类型;

通达信如何随股显示编程结果?

没明白你说的什么意思啊,画一张简图示意一下

股票公式编程 MT4编程 请高手帮忙!!

INPUT:K1(2010,1990,3000),K2(1,1,12),K3(1,1,31);

RQ:=(K1-1900)*10000+K2*100+K3;

指定日期价:REF(C,BARSLAST(DATE<=RQ )),LINETHICK0;

涨跌幅:(C-指定日期价)/指定日期价*100,LINETHICK0;{相对于指定日期价的涨跌幅}

{涨跌幅:(C-REF(C,1))/REF(C,1)*100,LINETHICK0;}{相对于前一天的涨跌幅}

{根据条件画区间柱子}

STICKLINE( C>指定日期价  AND 涨跌幅>5 AND BARSTATUS=2, 指定日期价, C, 8, 0),COLORAA00AA;

STICKLINE( C<指定日期价 AND 涨跌幅<-5  AND BARSTATUS=2, 指定日期价, C, 8, 1),COLORFFAAAA;

{下面是画K线}

STICKLINE(C>O ,H ,L ,0 ,0 ),COLOR5050DD;

STICKLINE(C>O ,O ,C ,8 ,0 ),COLOR5050DD;

STICKLINE(C>O ,O ,C ,7,0 ),COLOR8080DD;

STICKLINE(C>O ,O ,C ,6 ,0 ),COLORA0A0DD;

STICKLINE(C>O ,O ,C ,5,0 ),COLORC0C0DD;

STICKLINE(C>O ,O ,C ,4,0 ),COLORD0D0DD;

STICKLINE(C>O ,O ,C ,3 ,0 ),COLORF0F0FD;

STICKLINE(C>O ,O ,C ,2,0 ),COLORF0F0FF;

STICKLINE(C>O ,O ,C ,1,0 ),COLOREEEFFF;

STICKLINE(C<=O ,H ,L ,0 ,0 ),COLORDDDD50;

STICKLINE(C<=O ,O ,C ,8 ,0 ),COLORDDDD50;

STICKLINE(C<=O ,O ,C ,7,0 ),COLORDDDD80;

STICKLINE(C<=O ,O ,C ,6 ,0 ),COLORDDDD90;

STICKLINE(C<=O ,O ,C ,5,0 ),COLORDDDDA0;

STICKLINE(C<=O ,O ,C ,4,0 ),COLORDDDDB0;

STICKLINE(C<=O ,O ,C ,3 ,0 ),COLORFDFDC0;

STICKLINE(C<=O ,O ,C ,2,0 ),COLORFFFFE0;

STICKLINE(C<=O ,O ,C ,1,0 ),COLORFCFCF9;

{标示指定日期价}

PARTLINE(指定日期价,DATE>=RQ),COLORFFAA99,DOTLINE;{画横虚线----指定日期价}

DRAWTEXT( BARSTATUS=2, 指定日期价,NUMTOSTR( BARSLAST(DATE<=RQ ))+'天前价'+ NUMTOSTR(指定日期价)),COLOR00FFFF,ALIGN2;{显示指定日期价文字}

{将如下文字复制粘贴到参数精灵

*******************************

指定以下日期

Param#1 年

Param#2 月

Param#3 日

********************************

};