当前位置:首页 > 问答

通达信连续有庄选股公式

我来帮TA回答

通达信选出30天内连续三个涨停的选股公式,一字板也行?

可以编写通达信30天内出现连续3个涨停的选股公式,但现在的涨停分很多种,并且原来创业10%现在是20%,还有科创,普通的10%,还有st,涨幅都不一样,你要说明清楚是全计算呢,还是计算某几种呢,还有需要不需要历史验证呢。再有你这连续3个涨停是必须3个呢,还是3个及以上都可以呢条件要说明清楚才好编写公式。

效果如图。

通达信 统计7天内个股出现过5天连续上涨的选股公式

COUNT(LAST(C>REF(C,1)>=5,7)=1;
或者
COUNT(SUM(C>REF(C,1),5)=5,7)=1;

求通达信选股公式:两天连续出现开盘价相同的股票公式

可以编写连续两天出现开盘价相同的选股公式效果如下图。

通达信 庄家抬轿做“有庄控盘”和“高度控盘”两个选股公式

VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
有庄控盘:=IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0);
VAR2:=100*WINNER(CLOSE*0.95);
高度控盘:=IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0);
REF(C,1)>REF(C,2) AND 有庄控盘 AND 高度控盘;

请将以下公式合并成通达信选股公式

DIFF:=EMA(CLOSE,30)-EMA(CLOSE,120);
DEA:=EMA(DIFF,12);
A1:=DIFF>DEA;
中期方向线:=DIFF-DEA;
MB:=EMA(中期方向线,20);
超买线:=MB+1.96*STD(中期方向线,9);
N1:=9;N2:=5;
MTM:=C-REF(C,1);
主力轨迹:=100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1);
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR21:=SMA(ABS(HIGH-VAR1),13,1)/SMA(MIN(HIGH-VAR1,0),10,1);
VAR31:=EMA(VAR21,10);
VAR41:=HHV(HIGH,33);
VAR51:=EMA(IF(HIGH>=VAR41,VAR31,0),3);
主力拉高:=IF(VAR51<REF(VAR51,1),VAR51,0);
XG:主力拉高REF(主力轨迹,1) AND 中期方向线>REF(中期方向线,1) AND 超买线>REF(超买线,1);

通达信选股公式:下引线比实体长3倍或者3倍以上。

下影线:MIN(C,O)-L;
实体:ABS(C-O);
XG:下影线>=实体*3;
公式已经测试通过,谢谢!
参考资料:http://tieba.baidu.com/f?kw=%B9%C9%C6%B1%B9%AB%CA%BD%D7%A8%BC%D2