当前位置:首页 > 问答

超准短线暴涨指标源码

我来帮TA回答

通达信-超级短线指标12个(附源码)

连续三个会计年度亏损才会退市的.

请高手把下面的通达信公式改为有关 买点 买入 短线暴涨 绝对底部等买入信号的选股公式

选股公式的输出只能是一个,所以你以上的四个买入信号必须分四个选股公式编辑:
(一)"短线暴涨"选股公式:
MA5:=MA(C,5);
MA6:=MA(C,6);
MA10:=MA(C,10);
MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
乖离2:=(MA20-MA30)/MA30*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
MAX1:=MAX(MA20,MA30);
MAX2:=MAX(MAX1,MA60);
MIN1:=MIN(MA20,MA30);
MIN2:=MIN(MIN1,MA60);
K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
VAR2:=IF(K1<=8,1,0);
短线暴涨:IF(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)
AND MA(V,60)>REF(MA(V,60),1),5),1,0);
(二)"买入"选股公式:
MA5:=MA(C,5);
MA6:=MA(C,6);
MA10:=MA(C,10);
MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
乖离2:=(MA20-MA30)/MA30*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
MAX1:=MAX(MA20,MA30);
MAX2:=MAX(MAX1,MA60);
MIN1:=MIN(MA20,MA30);
MIN2:=MIN(MIN1,MA60);
K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
VAR2:=IF(K1<=8,1,0);
买入:IF(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30 AND J1>MJ1 AND MA60>REF(MA60,1) AND COUNT(J1<1,3)>=1 ,1,0);
(三)"买点"选股公式:
MA5:=MA(C,5);
MA6:=MA(C,6);
MA10:=MA(C,10);
MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
乖离2:=(MA20-MA30)/MA30*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
MAX1:=MAX(MA20,MA30);
MAX2:=MAX(MAX1,MA60);
MIN1:=MIN(MA20,MA30);
MIN2:=MIN(MIN1,MA60);
K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
VAR2:=IF(K1<=8,1,0);
XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
买点:IF(FILTER(((XL1 > 0) AND LOW),5),1,0);
(四)"绝对底部"选股公式:
MA5:=MA(C,5);
MA6:=MA(C,6);
MA10:=MA(C,10);
MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
乖离2:=(MA20-MA30)/MA30*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
MAX1:=MAX(MA20,MA30);
MAX2:=MAX(MAX1,MA60);
MIN1:=MIN(MA20,MA30);
MIN2:=MIN(MIN1,MA60);
K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
VAR2:=IF(K1<=8,1,0);
XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
绝对底部:IF((XL3 > 0),1,0);

求一套简单好用的超短线选股公式准确率80%以上就行了!

我觉得这个问题比较有趣。

短线暴涨选股公式

M1:=30;P2:=100;
VAR11:=(C+H+O+L)/4;
反弹:=EMA(EMA(EMA(HIGH,5),5),5)*0.95;
买入:=XMA(VAR11,M1)*(1-P2/1000);
XG:=CROSS(买入,反弹);
暴张:XG;
由于"买入"公式引用“未来数据”代码,是无法进行准确选股,选取出来的结果也是会漂移不定。

通达信的几个好用指标

均线必用,记得每次看盘都切换下周线月线来看,96 ENTER——切换成日线,97 ENTER换周线,98 ENTER切换月线。
MACD判断趋势,MACD理论中背离相对应用比较广泛,金叉死叉的话需要和均线量线共振才可靠。
成交量VOL指标,多观察底部和顶部量的特征。
有这三个指标其实就够了,关键看你理解多少,悟到什么程度。

求一个通达信的短线买点准确率高的的指标

短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
中期:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
中长期:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
长期:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
个股资金线:=MA(C,1)/MA(REF(C,18),18)*100;
资金生命线:=MA(FORCAST(个股资金线,20),6);
资金生命线增仓:=(资金生命线-REF(资金生命线,1))/
REF(资金生命线,1);
短期<20 AND 长期>60 AND 中长期>50 AND
DIF>MACD AND DEA>MACD AND DIF>DEA AND
个股资金线>=资金生命线 AND 资金生命线增仓>0.01;