当前位置:首页 > 问答

通达信手机自动画线指标

我来帮TA回答

求高手做个通达信画线指标

这个题很难,

也许是我没有完全理解题意

网上找到一份通达信自动画线的源码,但不知道怎么导入进去,有没有知道的大师,能帮小白解决???

通达信公式导入安装方法


通达信公式导入操作步骤如下(下面举例以说明):

1、先将我们传送的文件解压到你选择的硬盘位置,记住文件存档位置。找到所接收文件。

2、点击该文件,打开,如图,并点击“解压到”。然后选择文件存放位置,记住文件存放位置。

3、打开交易软件到行情显示窗口,点击“功能”按钮,在“专家系统”里选“公式管理器”,点击进入。在公式管理器窗口点击“导入公式”



4、选择导入文件,点击返回按钮,点击“我的电脑”,点击窗口右下方的“打开”按钮,找到刚才存放文件的硬盘,打开,找到存放文件的文件夹,选择该文件,打开。截图介绍如下,一步一步进行。(注意:此处是以副图指标导入举例。其它如主图,同于副图,选股公式导入到“条件选股公式”里,交易系统公式导入到“交易系统公式”里即可。安装步骤基本一样,若通达信的版本有细微差别,请诸君按照基本步骤做就行了。有差别的地方,可以结合诸君自己的版本稍作改动。)


5、找到文件点击打开后,公式开始导入软件系统。在“其它类型”前的方框里点一下,然后点右下方的“确定”按钮,公式就导入到系统里了。一般导入到“其它类型”里,是为了查找方便。主图及副图公式自动归入“技术指标公式”类,选股公式自动归入“条件选股公式”类,交易系统提示公式自动归入“交易系统公式”类。公式成功导入后,点击“关闭”按钮,退出公式管理器。

6、回到行情窗口,任选个股,按Enter键进入走势分析窗口,先点副图框一下,以确定将该副图更换为我们需要的副图,再点击“全部”按钮,再点“技术指标”类下的“其它类型”前的+号,找到刚才导入的指标公式,然后点“确定”。

7、然后,刚才的副图就换成我们需要的副图了,当然,我们可以任意更换所需要的指标。


8、主图指标的选择与副图相似,但略有不同,故简介于次:在主图上点右键,再点“主图指标”,然后点“选择主图指标”,进入主图指标类,选择刚才导入的主图公式或其它我们要查看的主图公式,点“确定”,就行了。


确定后,一般情况下,通达信系统会自动设为默认,下次打开行情分析时,出现的就是这次选择的指标,若有时出现变化,可以重新进行一次设定就好。




股票公式专家团为你解答,希望能帮到你,祝投资顺利。

求通达信自动画线公式

这个问题要参考绘图函数DRAWLINE的应用,举例如下:
DRAWLINE 绘制直线段
在图形上绘制直线段。
用法:DRAWLINE(COND1,PRICE1,COND2,PRICE2,EXPAND)
当COND1条件满足时,在PRICE1位置画直线起点,当COND2条件满足时,在PRICE2位置画直线终点,EXPAND为延长类型。
例如: DRAWLINE(HIGH>=HHV(HIGH,20),HIGH,LOW<=LLV(LOW,20),LOW,1) 表示在创20天新高与创20天新低之间画直线并且向右延长。
由于你提供的信息有限,只能回答到这一步了,仅供参考。

请高手中的高手,编写一个通达信的自动画线公式,(包括长期趋势,中短期趋势线)

{N:=75;P:=5;P1:=10; 参数范围1---100}
A1:=REF(H,P)=HHV(H,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);
E1:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
F1:=E1>REF(E1,1);
短压:DRAWLINE(D1,H,F1,H,1),COLORCYAN,DOTLINE;
A2:=REF(L,P)=LLV(L,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);
E2:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
F2:=E2>REF(E2,1);
短支:DRAWLINE(D2,L,F2,L,1),COLORLIRED,DOTLINE;
AA1:=REF(C,P1)=HHV(C,2*P1+1);
BB1:=FILTER(AA1,P1);
CC1:=BACKSET(BB1,P1+1);
DD1:=FILTER(CC1,P1);
EE1:=BACKSET(ISLASTBAR,BARSLAST(DD1)+1);
FF1:=EE1>REF(EE1,1);
长压:DRAWLINE(DD1,H,FF1,H,1),COLORGREEN LINETHICK2;
AA2:=REF(L,P1)=LLV(L,2*P1+1);
BB2:=FILTER(AA2,P1);
CC2:=BACKSET(BB2,P1+1);
DD2:=FILTER(CC2,P1);
EE2:=BACKSET(ISLASTBAR,BARSLAST(DD2)+1);
FF2:=EE2>REF(EE2,1);
长支:DRAWLINE(DD2,L,FF2,L,1),COLORRED LINETHICK2;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
突破:C>短压 OR C> 长压,NODRAW;
DRAWICON(突破 AND REF(突破,1)=0,L*0.99,1);
手动调节参数以达到最佳效果,一定要提防假突破。

请教哪位高手老师编写一个“利用趋势线选股公式”,谢谢

m12:=expma(close,12);

m50:=expma(close,50);

value_a1:=ref(every(m12<=ref(m12,1),2),1) and m12>=ref(m12,1);

value_a2:=between((m12-m50)/m50*100,0,1);

value_a:=value_a1 and value_a2;

value_b1:=(close-ref(close,1))/ref(close,1)*100;

value_b2:=macd.macd>=ref(macd.macd,1) and macd.macd>=0;

value_b3:=abs(ref(macd.macd,1))/abs(macd.macd)>=1.8 and macd.macd<0;

value_b4:=vol/ref(vol,1)>=2;

value_b:=value_b1>=2.5 and value_b3 and value_b4;

value:value_a and value_b;

效果如下图所示:

请高手编辑一个上升趋势线的支撑买点选股公式,或下降趋势线的选股公式!股价在靠近趋势线的地方为

图形化的提示,通达信有的版本有这种功能!