当前位置:首页 > 问答

通达信主力资金指标

我来帮TA回答

通达信 选股 请高手把下面的公式 主力资金和拉升资金同时满足大于零时,作一个选股公式,谢谢。

VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:=IF(VAR1D>0.015,VAR1F,0)/45;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:=POW(VAR11,3)*0.1+POW(VAR11,1);
BARSLASTCOUNT(拉升资金>0 AND 主力资金>0)=1;

通达信软件免费的主力资金线

这个是我珍藏的股票指标公式,送给你,主力资金线(通达信),源码下面网址里有图片演示.
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+ (CLOSE-LOW)),VOL/2))/25000,LINICK0;
卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0- AA*(HIGH-LOW),0-VOL/2))/25000,LINICK0,COLORCYAN;
一日资金流入:AMOUNT*买量*0.768/10000,COLORRED,LINICK0;
一日资金流出:AMOUNT*卖量/10000,COLORGREEN,LINICK0;
净额:一日资金流入+一日资金流出,LINICK0;
十日飘红:COUNT(净额>0,10),COLORRED;
连续飘红:LAST(净额>0,3,1);
STICKLINE(净额>0,0,净额,3,0),COLORRED,LINICK2;
STICKLINE(净额<0,净额,0,3,0),COLORGREEN,LINICK2;
0,POINTDOT,COLORWHITE;

求助通达信短线主力资金指标公式和精装版的主力先锋指标公式!谢谢了

N:=7;
M:=5;
VAR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
B:=SMA(VAR1,N,1);
VAR2:=SMA(B,M,1);
STICKLINE(B>VAR2,B,VAR2,0.8,1),COLORRED;
STICKLINE(B<VAR2,B,VAR2,0.8,0),COLORGREEN;
MAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
短高: 90,COLORGREEN;
高抛: 80,DOTLINE,COLORYELLOW;
MAR2:=LLV(LOW,34);
MAR3:=HHV(HIGH,34);
SK:=EMA((MAR1-MAR2)/(MAR3-MAR2)*100,13);
SD:=EMA(SK,3);
STICKLINE(SK<SD,SK,SD,0.8,0),COLORCYAN;
STICKLINE(SK>SD,SK,SD,0.8,1),COLORMAGENTA;
低吸: 20,DOTLINE,COLORYELLOW;
短底: 10,COLORRED;
中值:B,NODRAW;
短值:SK,NODRAW,COLORMAGENTA;
STICKLINE(SK>=90 OR B>=90,96,101,4,1),COLORYELLOW;
STICKLINE(B>=90 AND SK>=90,96,101,4,0),COLORYELLOW;
STICKLINE(SK<=10 OR B<=10,-1,4,4,1),COLORBLUE;
STICKLINE(B<=10 AND SK<=10,-1,4,4,0),COLORBLUE;
STICKLINE((SK<=10 OR B<=10) AND B>REF(B,1) AND SK>REF(SK,1),-1,4,4,1),COLOR7F00FF;
STICKLINE(B<=10 AND SK<=10 AND B>REF(B,1) AND SK>REF(SK,1),-1,4,4,0),COLOR7F00FF;
STICKLINE((SK>=90 OR B>=90) AND B<REF(B,1) AND SK<REF(SK,1),96,101,4,1),COLORWHITE;
STICKLINE(B>=90 AND SK>=90 AND B<REF(B,1) AND SK<REF(SK,1),96,101,4,0),COLORWHITE;
这是主力先锋指标。你先试着用用

请高手把通达信的这条主力资金(开始控盘、控盘、主力出货、主力吸货)指标公式源码改为可在大智慧上使用

VAR2:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);

VAR3:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);

VAR4:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);

VAR5:=(((VAR2 + (2 * VAR3)) + (3 * VAR4)) / 6);

VAR6:=MA(VAR5,3);

开始控盘:(VAR6 <= (0 - 10)),COLOR00AAFF;

STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),3.5,0),COLOR00AAFF;

STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),3.5,0),COLOR0044FF;

STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),2.5,0),COLOR0088FF;

STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),3,0),COLOR00AAFF;

VAR1:=EMA(EMA(CLOSE,3),1);

控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

STICKLINE(控盘<0,控盘,0,3.5,0),COLORFFAA00;

STICKLINE(控盘<0,控盘,0,3.5,0),COLORFF4400;

STICKLINE(控盘<0,控盘,0,2.5,0),COLORFF8800;

STICKLINE(控盘<0,控盘,0,0,0),COLORFFAA00;

主力出货:0,COLORFFAA00;

STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,3.5,0),COLOR000088;

STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,2.5,0),COLOR0000AA;

STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,1.5,0),COLOR0000CC;

STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,1,0),COLOR0000EE;

主力吸货:0,COLOR0000FF;

STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,3.5,0),COLOR008800;

STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,2.5,0),COLOR00AA00;

STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,1.5,0),COLOR00CC00;

STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,1,0),COLOR00EE00;

STICKLINE("DDX.DDX"<0,0,"DDX.DDX",3.5,0),COLOR008800;

STICKLINE("DDX.DDX"<0,0,"DDX.DDX",2.5,0),COLOR00AA00;

STICKLINE("DDX.DDX"<0,0,"DDX.DDX",1.5,0),COLOR00CC00;

STICKLINE("DDX.DDX"<0,0,"DDX.DDX",1,0),COLOR00EE00;

对倒出货洗盘:0,COLOR00FF00;

黄色底部吸货:0,COLORYELLOW;


DRAWTEXT(CROSS(控盘,0),0-3,'买。追'),COLORFF00FF;

DRAWTEXT(CROSS(0,控盘),0-0,'卖'),COLORGREEN;

DATA:=5;

{多头买入} DRAWICON(ZIG(3,DATA)>REF(ZIG(3,DATA),1)

AND REF(ZIG(3,DATA),1)<=REF(ZIG(3,DATA),2)

AND REF(ZIG(3,DATA),2)<=REF(ZIG(3,DATA),3),L*0.98,7);

{多头卖出} DRAWICON(ZIG(3,DATA)<REF(ZIG(3,DATA),1)

AND REF(ZIG(3,DATA),1)>=REF(ZIG(3,DATA),2)

AND REF(ZIG(3,DATA),2)>=REF(ZIG(3,DATA),3),H*1.02,8);

哪位大哥能给我这个主力资金进出指标公式,非常感谢1如图

主力资金进出指标公式通达信同花顺都可用

VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);

VAR3:=EMA(VAR2,10);VAR4:=LLV(LOW,33);

VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);

主力进场:VAR5>REF(VAR5,1);

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,5,0 ),COLORRED;

洗盘:STICKLINE(VAR5<REF(VAR5,1),0,-VAR5,5,0),COLORGREEN;

谁有通达信中线主力资金指标公式

N:=24;
VAR1:= EMA(EMA(CLOSE,13),13);
控盘指数: (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000,POINTDOT,COLORFFCCCC;
STICKLINE(控盘指数<0,控盘指数,0,2,0),COLORGRAY;
无庄控盘: 控盘指数<0,LINICK0,COLORGRAY;
STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>0 AND 控盘指数<3,控盘指数,0,2,1),COLORRED;
STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>0 AND 控盘指数>3,控盘指数,0,2,1),COLORRED;
STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>3,控盘指数,3,4,1),COLORFF00FF;
主力控盘: 控盘指数>REF(控盘指数,1) AND 控盘指数>0,LINICK0,COLORRED;
STICKLINE(控盘指数<REF(控盘指数,1) AND 控盘指数>0,控盘指数,0,2,0),COLOR00FF00;
控盘减弱: 控盘指数<REF(控盘指数,1) AND 控盘指数>0,LINICK0,COLOR00FF00;
VARA:= EMA(0.667*REF(控盘指数,1)+0.333*控盘指数,2);
STICKLINE(控盘指数>VARA,控盘指数,VARA,2,0),COLORRED;
B2:= 控盘指数>VARA;
准备: B2>REF(B2,1) AND 控盘指数<(-2),COLORYELLOW;
DRAWTEXT(准备,3,'准备'),COLORYELLOW;
B1:= (控盘指数>REF(控盘指数,1) AND 控盘指数>0)=1;
开始控盘: B1>REF(B1,1),COLORMAGENTA,LINICK3;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(X,13);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWICON(FILTER(买=1,5),L*0.11,1);
DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,COLORWHITE,LINICK1;
DEA:EMA(DIFF,9),COLORYELLOW,LINICK1;
MACD:2*(DIFF-DEA), COLORSTICK;
MACD1:=2*(DIFF-DEA),COLORRED,NODRAW;
MACD2:=EMA(MACD1,3),COLORCYAN,NODRAW;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLORYELLOW;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORGREEN;
S1:=MACD<0;
S2:= (MACD>=0);
S3:=BARSLAST(CROSS(DIFF,DEA));
S4:=REF(S3,S3+1);
S5:=DEA>REF(DEA,S4);
S6:=DEA;
上成立:=CROSS(DIFF,DEA) AND S5;
下成立:=CROSS(DIFF,DEA) AND S6;
L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
L2:=EMA(L1,9);
L3:=BARSLAST(CROSS(L1,L2));
L4:=REF(L3,L3+1);
L5:=L2;
变盘:CROSS(L1,L2) AND L5,NODRAW,COLORD6FF9C;
STICKLINE(变盘,5,0,0,1),COLORD6FF9C;
LS:=IF(DIFF>DEA AND DIFF>0,1,0);
加速上扬:IF(REF(LS=0,1) AND LS=1,0.1,0);
XG1:CROSS(MACD1,MACD2) AND MACD1<0,NODRAW;
XG2:CROSS(DIFF,DEA),NODRAW;
M1:=MACD>REF(MACD,1) AND DIFF<DEA;
绿柱短了:M1 AND COUNT(M1,10)=1 AND C>MA(C,55) AND COUNT(MACD<0,5)>=5,NODRAW;
DRAWTEXT(绿柱短了,MACD,'买点来了');
DIFL:=EMA(V,12)-EMA(V,26);
DIF:=EMA(C,12)-EMA(C,26);
BL:=DIFL>REF(DIFL,1) AND DIF<REF(DIF,1);
四天: REF(BL,3)=1 AND REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
三天:REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
{VERTLINE(上成立,3),COLORYELLOW;
VERTLINE(下成立,3),COLORRED;}
IF(DIFF>DEA,DIFF,DRAWNULL),COLORFF11CC,LINICK1;
IF(DIFF>DEA AND DIFF<0,DIFF,DRAWNULL),COLORRED,LINICK1;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DRAWTEXT(FILTER(D>80,6),H*1.018,'D>80');
DRAWTEXT(FILTER(CROSS(K,D) AND D<26,6),H*0.95,'KD低位金叉'),COLORFFCCCC;
STICKLINE(FILTER(CROSS(K,D) AND D<26,6),H*0.97,H*0.95,4,0),COLORFFCCCC;
DIFFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEAF :=EMA(DIFFF,9);
MACDD:=2*(DIFFF-DEAF);
DRAWTEXT(FILTER(CROSS(DIFFF,DEAF) AND DEAF<0,6),L-0.02,'MACD低位金叉'),COLORRED;
STICKLINE(FILTER(CROSS(DIFFF,DEAF) AND DEAF<0,6),L-0.02,L-0.1,4,0),COLOR00FF00;
DRAWTEXT(FILTER(CROSS(DIFFF,DEAF) AND DEAF>0,13),H+0.25,'MACD下拐点'),COLORYELLOW;
STICKLINE(FILTER(CROSS(DIFFF,DEAF) AND DEAF>0,13),H+0.02,H+0.12,4,0),COLORBLUE;
DRAWTEXT(FILTER(CROSS(MACDD,0),13),L*0.65,'MACD上拐点'),COLORRED;
STICKLINE(FILTER(CROSS(MACDD,0),13),L*0.97,L*0.95,4,0),COLORWHITE;
ROC:=(CLOSE-REF(CLOSE,21))/REF(CLOSE,21)*100;
DRAWTEXT(FILTER(CROSS(ROC,0),6),L-2.25,'骗线拐点'),COLORWHITE;
STICKLINE(FILTER(CROSS(ROC,0),6),L-0.02,L-0.15,4,0),COLORFF00FF;
我是用这个的